Sync-Problem with Zonealarm Firewall

If BirdieSync 1.x constantly replaces your girlfriend's phone number with your mother's one, this forum is for you...
Post Reply
Jules
Posts: 2
Joined: Sun Dec 06, 2009 10:40 am

Sync-Problem with Zonealarm Firewall

Post by Jules » Sun Dec 06, 2009 10:49 am

Hello,
my problem is that I can't sync between Thunderbird Lightning and my Mobile if the Firewall is in use. As soon as I turn of the Firewall, syncronization works perfect. Does anbody know which setting I have to set in Zonealarm in order to sync WHILE Zonealarm is in use.

I'm using BirdieSync 1.7.2.0, Firewall Zonealarm 7.1.254 (the current version now), Windows Mobile Device Center 6.1, Windows Vista SP1 and on my device Windows Pocket 6.5.

There is a posting with older versions of Zonealarm, but this didn't help with the new version.

I like Birdiesyc!

Thanks for help!
Jules Bach

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Re: Sync-Problem with Zonealarm Firewall

Post by Birdy » Mon Dec 07, 2009 11:40 am

Hello Jules,

I made a test with a fresh installed copy of Zone Alarm but had no problem synchronizing. But ActiveSync uses a lot of different ports. You must ensure that Wmdc.exe, Wmdhost.exe and Thunderbird.exe are authorized for incoming/outgoing connections. But the svchost.exe proces also need to be authorized for some specific ports. The simplest solution is to start from a clean installation of Zone Alarm, connect the mobile device and give the authorization to all the programs which request it.

Another solution is to stop using the RNDIS connection mode and to switch to the serial mode as described at the end of this FAQ topic.
Birdy

Jules
Posts: 2
Joined: Sun Dec 06, 2009 10:40 am

Re: Sync-Problem with Zonealarm Firewall

Post by Jules » Mon Dec 07, 2009 12:31 pm

Hello Birdy,

thanks for your fast help! My settings in Zonealarm were all right. So I've found the problem in the mobile. On Windows Mobile 6.5 (german version), there is a setting at: Start/Settings/More (Andere)/USB to PC (USB zu PC)/ActiveSync. There is a checkbox to activate fast file-syncronization. This was checked. I've unchecked it, and now it connects and syncs perfectly.

Jules

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Re: Sync-Problem with Zonealarm Firewall

Post by Birdy » Mon Dec 07, 2009 12:35 pm

Yes, you did what I recommended in the last part of my post (said with other words: when you uncheck "faster data synchronization", you switch to the serial connection mode). The serial mode is generally more reliable than the RNDIS mode.
Birdy

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests