Error selecting Address book

If BirdieSync 1.x constantly replaces your girlfriend's phone number with your mother's one, this forum is for you...
Post Reply
Henry
Posts: 7
Joined: Thu Nov 16, 2006 10:53 am

Error selecting Address book

Post by Henry » Thu Mar 01, 2007 11:16 am

Using Birdiesync 1.5.0.0 there is an error when I open the Birdiesync Options in Thunderbird: The maximum body size has an invalid value.
The OK button is greyed out so I can't select an address book.
I've sent a mail with the logfiles.

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Post by Birdy » Thu Mar 01, 2007 11:20 am

There was a problem in 1.4.0.3 which by default set the maximum body size value to 0 (which should be impossible). Couldn't you set it to 25 instead of 0 ? That should enable the "OK" button.
Birdy

Henry
Posts: 7
Joined: Thu Nov 16, 2006 10:53 am

Post by Henry » Thu Mar 01, 2007 11:41 am

Thanks for the quick response. I have altered the value and ran into another error. Replacing the preferences.xml with an old value (prior to 1.4.0.3) solved the problems. Differences between the two where:
new <-> old
MailPastPeriodNumber: 0 <-> -1
MailPastPeriodUnit: 0 <-> -1
synchronizationStartAlert: 1 <-> 0
synchronizationEndAlert: 1 <-> 0

Regards,

Henry

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Post by Birdy » Thu Mar 01, 2007 11:48 am

Yes that's right: two fields were not propely set in 1.4.0.3:
The maximum mail body size (which was set to 0)
The limit to synchronize past mails (which was set to "Custom" but with no period defined)

So to correct the problem set:
Maximum mail body size: 25
Limit to synchronize past mails: Unlimited (or fill the custom fields)
Birdy

mrozenhart
Posts: 4
Joined: Fri Mar 02, 2007 9:55 am

Post by mrozenhart » Fri Mar 02, 2007 9:56 am

Where can I find this XML file?
I have the same problem...

mrozenhart
Posts: 4
Joined: Fri Mar 02, 2007 9:55 am

Post by mrozenhart » Fri Mar 02, 2007 10:31 am

Never mind.. Solved the problem..

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Post by Birdy » Fri Mar 02, 2007 10:45 am

Just for other users who meet the same problem:
Normally, you don't need to modify the xml file. You only have to properly fill the fields in BirdieSync options ("maximum mail body size" and "limit to synchronize past mails" for instance)
If you have problems doing it, signal it.
Birdy

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests