lightning 0.7 pre

If BirdieSync 1.x constantly replaces your girlfriend's phone number with your mother's one, this forum is for you...
pwvandeursen
Posts: 23
Joined: Thu Aug 16, 2007 4:55 pm

lightning 0.7 pre

Post by pwvandeursen » Sun Aug 19, 2007 2:06 pm

Hi,

I just tried birdysync, and would like to use it further, however I have lightning 0.7 pre and can thus not use the calender. Is there a work around(unsupported of course) because I cannot go back to 0.5 at this moment

Thanks
Patrick

VIPek
Posts: 1
Joined: Sun Aug 26, 2007 5:46 am

Post by VIPek » Sun Aug 26, 2007 5:53 am

Hi!

I'm joining the question ...
Any solution ?

Regards,
Tomasz Adamczuk

pwvandeursen
Posts: 23
Joined: Thu Aug 16, 2007 4:55 pm

Post by pwvandeursen » Thu Aug 30, 2007 7:59 am

Still no update.....

ANybody have an answer to this question. I would really like to be able to try 0.7 if that is possible (and hopefully share the experiences and the odd isuue we might encounter :wink: )

Patrick

pwvandeursen
Posts: 23
Joined: Thu Aug 16, 2007 4:55 pm

Post by pwvandeursen » Sat Sep 01, 2007 11:19 am

Birdy,

is there some way we can still use lightning 0.7?

Patrick

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Post by Birdy » Sat Sep 01, 2007 12:06 pm

The present version of BirdieSync is not compatible with 0.7 development release. I am sorry about it.
Birdy

rfn
Posts: 30
Joined: Tue May 16, 2006 4:10 am
Location: Bourges, France

Post by rfn » Sun Sep 02, 2007 6:26 am

Okay, but are you working around that or will you have to wait until the official release ?


Olivier

pwvandeursen
Posts: 23
Joined: Thu Aug 16, 2007 4:55 pm

Post by pwvandeursen » Mon Sep 03, 2007 3:18 pm

Yes please let us know. I really like the program, but am already using 0.7 so would like that included. can you give us a time frame when it will be included?

thanks
Patrick

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Post by Birdy » Thu Sep 06, 2007 9:36 am

Sorry, no schedule yet. The priority is given to the development of new features. Furthermore, for now 0.7 version is a moving target still in continuous development and would likely require continual adapatation of BirdieSync...
Birdy

pwvandeursen
Posts: 23
Joined: Thu Aug 16, 2007 4:55 pm

Post by pwvandeursen » Wed Sep 12, 2007 8:14 pm

Well I devized some sort of work around. It's not perfect (only one way, from t-bird to your mobile), but you can then use 0.7 in thunderbird and still use birdy sync to get the info to your mobile (until Birdy updates his program, which I will be awaiting with great anticipation! probably soon as the string freeze is already next week and the release of RC1 as well and the final in the first half of October). Here it goes.


1. go to your profile folder and backup a version of your profile in a seperate dir. We will use this later on.#
2. install lightning 0.5. and close thunderbird
3. start the profile manager (thunderbird -profilemanager)
4. rename the original profile to 0.5
5. make a new profile and call it 0.7
6. open the 0.7 profile (you don't have to enter anything, just close it all again) close thunderbird
7. now copy the back-up profile to the newly created profile (delete everything in the profile first)

8. use a sync program like synckack to keep the data between the two profile synced, as we will use only one profile, and birdy will use the other.
We thus need to have all the data of 0.7 profile copied to the 0.5 profile, except the extension of 0.5 itself. In synkback this is possible, by unticking the folder where the calendar extension is stored in.

Now when birdy wants to sync your mobile, it will open the initial thunderbird profile (with the 0.5 version)

use thunderbird -profilemanager to open the 0.7, and after that when you open thunderbird it will automatically be the 0.7 profile

Key here is to have thunderbird closed when active sync starts, otherwise you will just get the attention remark.

Hope this is clear.

So just to recap.

Make a the original profile with 0.5 which birdy uses to sync with your mobile.
You use thunderbird with a new 0.7 profile
Use syncback to keep the two profiles, except the extension synced (the data with all your events is stored in storage.sdb in the root of your profile, which gets synced!)

remember to have thunderbird closed when active sync starts to sync with your device, and to close thunderbird after the sync is completed.

Good luck

(it looks like all goes well and all events are copied.....)

Golfy
Posts: 4
Joined: Sat Apr 07, 2007 11:01 am
Location: Grenoble

Post by Golfy » Thu Sep 13, 2007 12:52 pm

What are the new features with lightning 0.7 ?
are they so important that it needs to be installed ?

What about restrictions with date (ex: appointment before 1970) ?
Thanks for any useful information...

pwvandeursen
Posts: 23
Joined: Thu Aug 16, 2007 4:55 pm

Post by pwvandeursen » Sat Sep 15, 2007 8:54 am

I would't say they are essential, But I really like 0.7. therefore I tried to search for a way to work with it. I know it is not a very nice way to work, but for me it works.

for what your question on 1970, I don't know, as I don't have any appointments before 1970 (and don't think I will get them anymore... :wink: )

Patrick

bernis
Posts: 1
Joined: Mon Sep 17, 2007 2:43 pm

Post by bernis » Mon Sep 17, 2007 2:48 pm

even simpler solution:
1. get lightning 0.7pre (lightning.xpi)
2. rename it to lightning.zip
3. open the zip file and edit contained file install.rdf in notepad
4. replace "<em:version>0.7pre</em:version>" to "<em:version>0.5</em:version>"
5. rename lightning.zip back to lightning.xpi
6. install lightning.xpi addon

(if you don't have ability to edit files contained in zip, just extract the contents of the zip file, edit the install.rdf, and zip teh changed contents back to lightning.zip, then rename it to lightning.xpi and install)

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Post by Birdy » Tue Sep 18, 2007 6:52 pm

Be very carefull if you want to try 0.7pre. BirdieSync is not yet compatible with it: it can lead to crashes of Thunderbird or "attention required" while synchronizing events or tasks...
Birdy

pwvandeursen
Posts: 23
Joined: Thu Aug 16, 2007 4:55 pm

Post by pwvandeursen » Tue Sep 18, 2007 9:37 pm

Indeed, in both strategies mentioned above, It now results in attentions required, or thunderbird crashing. so unfortunately it is not yet completely 0.7 proof.....

Birdy
Site Admin
Posts: 3022
Joined: Tue Apr 18, 2006 11:43 am
Contact:

Post by Birdy » Thu Oct 25, 2007 8:58 pm

BirdieSync 1.6.3.0 was released and supports Lightning & Sunbird 0.7. :)

Before upgrading, don't forget to backup your Thunderbird or Sunbird profile directory.
If you installed the patches for calDAV or WCAP calendars, download new patches and install them again.
Birdy

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests