Page 1 of 1

birdiesync and Ligtning 0.3

Posted: Tue Oct 24, 2006 6:16 pm
by bricamac
My configuration: Thunderbird, Ligtning 0.3, ActiveSync 4.2.0 and birdiesync

Have just upgrade Lightning to the version 0.3 , now i could to any syncronisation I have got an error that says that "Thunderbird is already running,but is not responding..... the problem still even after one reboot.

Posted: Tue Oct 24, 2006 6:36 pm
by Birdy
Right after the problem, without restarting Thunderbird, could you send the logs DesktopProvider.log and ThunderbirdService.log (located in C:\Program Files\BirdieSync\log) to ?
I would also be interested in Preferences.xml (located in C:\Program Files\BirdieSync).

Posted: Tue Oct 24, 2006 7:51 pm
by Birdy
The Preferences.xml file had a format used by an old version of BirdieSync. Deleting it and reinstalling BirdieSync solved the problem.

Me Too

Posted: Wed Nov 22, 2006 11:02 am
by rfcvb72
Hi, I am having the same problem

I get the same message:

Thunderbird is already running,but is not responding.....

if Tbird is already open, although if I let the sync open it, it is fine, but as I have Tbird open on boot, it is a pain. I can tell from the display font that this is coming from Thunderbird, but it is definately due to the sync action.

I have tried leaving the Tbird path empty, but this does not help, is there anyway to disable the launch Tbird function?

This is on a clean install, Birdiesync, Lightning 0.3 and Tbird, Activesync 4.2 as well

My device is an unlocked XDA2i (HTC Alpine) running WM2003SE

hope you can help, its a great product otherwise, this issue is the only thing stopping me buying immediately!



Posted: Wed Nov 22, 2006 11:18 am
by rfcvb72
I did find this, maybe it will help ... _same_time

may thanks


Posted: Wed Nov 22, 2006 7:12 pm
by Birdy

Thank you for the link. Actually, another user had a similar problem. It was caused by the fact that Thunderbird process name was "THUNDE~1.EXE" instead of "thunderbird.exe". BirdieSync was not detecting properly that Thunderbird was already launched and tried to launch another instance causing the error message. A patched library solved his problem. Could you check the name of your Thunderbird process in the Task Manager and give me the result ?

Tbird Process

Posted: Wed Nov 22, 2006 7:23 pm
by rfcvb72
Hi Birdy, the name of my Tbird Process is also THUNDE~1.EXE

many thanks for the prompt attention



Posted: Wed Nov 22, 2006 7:29 pm
by Birdy
If you want, you can send me your version of DesktopProvider.dll to I will patch it to solve your proplem.

Is it because I am using the GB localization?

Posted: Wed Nov 22, 2006 7:41 pm
by rfcvb72
Thanks Birdy, the file should be with you now, it just occurred to me, could this be a problem with the GB localization? perhaps this is why the process has a different name



Posted: Wed Nov 22, 2006 8:41 pm
by Birdy
Actually, I don't know the reason. In some cases, the name of the process is displayed as an old DOS short name instead of the usual long name. If someone has information about that, I would be happy to know it...
This problem will be addressed in next version.