Page 1 of 1

Problem with BirdieSync WM6.1 TB 6.0.1

Posted: Mon Sep 05, 2011 3:48 pm
by Phones

I'm having a problem with BirdieSync connecting to my TouchPro2 running WM6.1 and using Thunberbird 6.0.1

When the laptop (Vista 64 SP2) starts up, I briefly see the BirdieSync icon in the notification tray, but then it vanishes.
As such when my phone is connected I can't sync.

This has been occurring for a while, but TBH I put it down to upgrading BirdieSync with an older version of Thunderbird.
I just updated to the latest Thunderbird, and BirdieSync and am still getting the problem.

If I try to run BirdieSync directly I get this error...
This also is displayed if I try to run BirdieSync as Administrator.

I just noticed that if I look at the windows Mobile Device Centre, the sync options that used to be present for BirdieSync are showing the wrong icon and cannot be checked.

I have tried uninstalling BirdieSync from both my PC and phone, but this has not worked.

Any ideas?



Re: Problem with BirdieSync WM6.1 TB 6.0.1

Posted: Thu Sep 08, 2011 7:24 am
by Birdy
Hello Dave,

When you are in BirdieSync installation directory, look at BirdieSync.exe security settings (right click on the file, Properties/Security), do you have the "Read & execute" permission ticked ? If not, could you edit permissions for the current user and tick "Read & execute" ? (if your permissions are all grayed out, it means they are inherited: click on the "Advanced" button, on the "Change permissions" button, select your User account and untick "Include inheritable permissions from object parent", then you'll be able to edit the permissions)

Re: Problem with BirdieSync WM6.1 TB 6.0.1

Posted: Thu Sep 08, 2011 11:18 pm
by Phones
Thanks for the reply.

Looking at the properties for BirdieSync.exe security settings all my permissions are greyed out, but all the groups and users, which are
    Administrators (<MachineName>\Administrators)
    Users (<MachineName>\Users)
have ticks on the allow for Read & Execute (and no tick on deny).

Also, the problem has just manifest slight differently.

I noticed the BirdieSync icon was showing in the notification tray (previously it had vanished immediately after startup).
So I connected my phone, at which point I received a message that BirdieSync had stopped working, and the icon vanished.
Again if I now try to restart BirdieSync I get the
message again.

I did not think to screen grab the stopped working message this time.
The dialog had the option to debug, and I have Visual Studio 2008 on this PC, so if it occurs again I could try to save out a crash dump, if you think that would be of use? (assuming I can remember how to do that on a PC :o))



Re: Problem with BirdieSync WM6.1 TB 6.0.1

Posted: Fri Sep 09, 2011 8:57 am
by Birdy
So there might be 2 problems (one crash, one "Cannot access").

BirdieSync is automatically started when you log in but crash when you connect your device ?
If yes, right after you logged in, can you at least open BirdieSync window (double clicking on BirdieSync icon in the system tray) ?
Which executable path do you have when you look at BirdieSync.exe properties in Windows task manager ?

When you manually start BirdieSync, could you check that no other BirdieSync.exe process is running before you try to launch it ?
Is it the same path as shown previously in the task manager ? (to be sure it's the same executable)
Remove BirdieSync.log in:
C:\Users\<user name>\AppData\Roaming\BirdieSync\Log
(Application Data is a hidden folder: in explorer window, you must check the option "Show hidden files and folders")
When you get the error message, could you check that no new BirdieSync.log is created ?

Would the solutions mentioned here be usefull in your case ?

Re: Problem with BirdieSync WM6.1 TB 6.0.1

Posted: Sun Sep 11, 2011 11:39 am
by Phones

After looking at your link I tried disabling my firewall (Kaspersky Internet Security 12).

While it was disabled I could start BirdieSync manually, and a sync worked correctly.

Initially I paused Kaspersky for 3 minutes, which was sufficient time for a sycn.

I then disconnected the device, re-enabled Kaspersky and tried reconnecting. BirdieSync did not crash, but the device was not displayed as connected.

I then disabled Kaspersky for 1 minute and the device immediately connected in BirdieSync.

This time the sync was not completed before Kaspersky re-enabled, and when it did an error was displayed from BirdieSync saying the operation could not be completed.

So it looks as if Kaspersky is my problem.

Any ideas on a solution? otherwise I will go and bug Kaspersky, but I know from past experience their one to one customer service is (understandingly) not up to the response we get from you Birdy.



Re: Problem with BirdieSync WM6.1 TB 6.0.1

Posted: Mon Sep 12, 2011 8:52 am
by Birdy
It will be difficult to investigate on this problem. If BirdieSync was explicitly authorized in the Firewall, you may try to remove its authorization and authorizes it again to accept incoming and outgoing connections. But there might be problem with the USB connections which are managed by ActiveSync/WMDC drivers...
Also it is strange that you got the "Cannot access" error when you tried to manually start BirdieSync. That may be related to another problem. It could be interesting to see if for some reason, BirdieSync.exe is not listed as "blocked by user" in Kaspersky.

Re: Problem with BirdieSync WM6.1 TB 6.0.1

Posted: Tue Sep 13, 2011 7:15 pm
by Phones
We that was interesting, Birdiesync was in the untrusted section of the firewall.

Moving it to trusted and setting its permissions to allow seems to have worked.
Although Thunderbird failed to startup the first 2 times I tried to sync, on the 3rd attempt all worked fine, so I think that was it.