Page 1 of 1

Sync not working since update

Posted: Fri Jun 08, 2012 11:16 pm
by Vishara
Synchronization is no longer working for me as of just after upgrading to the update. I have never had a problem synchronizing before, either via WiFi or USB. I have not changed any of my settings, and have not done anything differently in this upgrade than I have in past upgrades (I usually keep up with the upgrades within a week or two.

When trying to sync over WiFi, there is no acknowledgement by my PC that the phone is even trying to connect.

When trying to connect over USB, my HTC sync works (at least as well as that's ever worked), but I get a pop-up from BirdieSync: "Cannot connect to Android mobile device", "Impossible to connect to Android device with a USB connection. Please reconnect the mobile device.", "If this problems persists: - Disable and enable again 'USB debugging' on the mobile device - Check that BirdieSync is still running on the mobile device (minimum version - Check that your firewall authorizes incoming and outgoing connections for BirdieSync.exe and adb.exe processes". The status icon / message indicates "No mobile device connected".

When I finished the initial install, I was able to synchronize successfully, but I have not been able to synch since. I've tried restarting the phone, and restarting the computer. I've tried re-installing the latest version of BirdieSync on the computer. I've tried re-installing the app on the phone. I've tried synching with my antivirus / firewall program not only off, but fully exited. I've confirmed the BirdieSync server address on the desktop and handheld match. I've re-entered the passwords. I've toggled the USB debugging checkbox as suggested. Nothing.

Anything obvious I'm missing?

Running on Windows XP
Android ICS (HTC Amaze)
BirdieSync on the phone
Comodo Internet Security Suite

Re: Sync not working since update

Posted: Sat Jun 09, 2012 12:02 am
by Vishara
Further clarification. USB sync via any means isn't working, but I get different issues depending on the method. The above described pop-up occurs if, upon plugging in the USB cord, I select the "HTC Sync" option from the phone's "Choose a connection type" menu. When I select "Disk drive", nothing happens at all, similar to using WiFi. Before this issue, if I selected either one, BirdieSync would trigger.

Re: Sync not working since update

Posted: Mon Jun 11, 2012 12:45 pm
by Birdy
Hello Vishara,

Do you remember which version of BirdieSync you had before having these problems ? Were you using Thunderbird 12.0 before ?
Solving the problem with Wi-Fi synchronization is usually simpler because it doesn't involve the use of adb.exe process provided by Google which is a bridge between the Android device and BirdieSync.
Can you confirm that BirdieSync.exe is running on your PC ?
Can you confirm that over Wi-Fi, your device share the same local network as your PC ? Do they share the same SSID ?
Does the IP address you entered in BirdieSync settings in the Android app begins with "192.168.0." ?
Do you have several IP addresses displayed in BirdieSync connection options on the desktop ? (BirdieSync window, menu File/Options, Connection tab)
On your Android device in BirdieSync app, what is the latest synchronization status displayed (something like, "connection to..." below the green icon) ?

Re: Sync not working since update

Posted: Wed Jun 13, 2012 5:19 am
by Vishara
Well this is odd. I was going through your questions, and decided to try checking the "Find host with BirdieSync" option on the android. It didn't work, in that the first time I tried it I got a pop-up on the android that it couldn't connect to the PC. I tried it a couple more times, and on each successive time got a pop-up that no host running BirdieSync could be found. So I unchecked the box, resumed using the desktop address (, and now it is working fine. :?